Disabling a jaws keystroke for a particular app.


Tony Malykh
 

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony


Mario
 

just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.


Tony Malykh
 

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony

On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.






Tony Malykh
 

I wish there was a "sticky" version of Insert+3 command in Jaws. That
is the one, that would bypass not only the following keystroke, but
keep bypassing all the keystrokes until I press the same sticky
keystroke again. I checked jaws manual and couldn't find anything
olike this.

On 5/7/17, Tony Malykh <anton.malykh@gmail.com> wrote:
That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.








Mike B. <mb69mach1@...>
 


Hi Tony,
 
Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.
 
Now, tab 1 time into a list of keystrokes for that application / program.
 
Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.
 
With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.
 
Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.
 
Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!

----- Original Message -----
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>



Dave...
 


One point on this process: If the keystroke is common across several applications, it may be located in a default key manager file. So it may be necessary to look there for that keystroke.
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 

----- Original Message -----
From: Mike B.
Sent: Sunday, May 07, 2017 21:30
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Tony,
 
Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.
 
Now, tab 1 time into a list of keystrokes for that application / program.
 
Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.
 
With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.
 
Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.
 
Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>



Mike B. <mb69mach1@...>
 


Hi Dave, Oregonian, woodworker, Engineer, Musician, and Pioneer,
 
Thanks a lot for adding that very important piece of info!  That thought totally slipped my feeble mind!
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!

----- Original Message -----
Sent: Sunday, May 07, 2017 10:03 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

One point on this process: If the keystroke is common across several applications, it may be located in a default key manager file. So it may be necessary to look there for that keystroke.
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 
----- Original Message -----
From: Mike B.
Sent: Sunday, May 07, 2017 21:30
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Tony,
 
Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.
 
Now, tab 1 time into a list of keystrokes for that application / program.
 
Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.
 
With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.
 
Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.
 
Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>



Dave...
 


Go Mariners!
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 

----- Original Message -----
From: Mike B.
Sent: Sunday, May 07, 2017 22:12
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Dave, Oregonian, woodworker, Engineer, Musician, and Pioneer,
 
Thanks a lot for adding that very important piece of info!  That thought totally slipped my feeble mind!
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 10:03 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

One point on this process: If the keystroke is common across several applications, it may be located in a default key manager file. So it may be necessary to look there for that keystroke.
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 
----- Original Message -----
From: Mike B
Sent: Sunday, May 07, 2017 21:30
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Tony,
 
Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.
 
Now, tab 1 time into a list of keystrokes for that application / program.
 
Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.
 
With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.
 
Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.
 
Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>



Mike B. <mb69mach1@...>
 


Damn straight, right behind the Angels!  LOL 
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!

----- Original Message -----
Sent: Sunday, May 07, 2017 10:28 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

Go Mariners!
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 
----- Original Message -----
From: Mike B.
Sent: Sunday, May 07, 2017 22:12
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Dave, Oregonian, woodworker, Engineer, Musician, and Pioneer,
 
Thanks a lot for adding that very important piece of info!  That thought totally slipped my feeble mind!
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 10:03 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

One point on this process: If the keystroke is common across several applications, it may be located in a default key manager file. So it may be necessary to look there for that keystroke.
 
Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer
 
 
----- Original Message -----
From: Mike B
Sent: Sunday, May 07, 2017 21:30
Subject: Re: Disabling a jaws keystroke for a particular app.

Hi Tony,
 
Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.
 
Now, tab 1 time into a list of keystrokes for that application / program.
 
Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.
 
With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.
 
Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.
 
Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.
Take care.
Mike
Sent from my iBarstool.  Go Dodgers!
----- Original Message -----
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>



george b <gbmagoo@...>
 

Hay dave yahoo a M’s fan.  My new guide dog has a record of 5 and 1 for the season.  Trying to get the M’s to put him on the payroll…lol

 

I am a weekend season ticket holder

 

From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of Dave Carlson
Sent: May 7, 2017 22:28
To: main@jfw.groups.io
Subject: Re: Disabling a jaws keystroke for a particular app.

 

Go Mariners!

 

Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer

 

 

----- Original Message -----

From: Mike B.

Sent: Sunday, May 07, 2017 22:12

Subject: Re: Disabling a jaws keystroke for a particular app.

 

Hi Dave, Oregonian, woodworker, Engineer, Musician, and Pioneer,

 

Thanks a lot for adding that very important piece of info!  That thought totally slipped my feeble mind!

Take care.
Mike
Sent from my iBarstool.  Go Dodgers!

----- Original Message -----

Sent: Sunday, May 07, 2017 10:03 PM

Subject: Re: Disabling a jaws keystroke for a particular app.

 

One point on this process: If the keystroke is common across several applications, it may be located in a default key manager file. So it may be necessary to look there for that keystroke.

 

Dave
Oregonian, woodworker, Engineer, Musician, and Pioneer

 

 

----- Original Message -----

From: Mike B

Sent: Sunday, May 07, 2017 21:30

Subject: Re: Disabling a jaws keystroke for a particular app.

 

Hi Tony,

 

Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K, until you get to, & press enter on Keyboard Manager.  You'll be in a list of applications, so use 1st letter navigation to get to the application / program you want to work with.

 

Now, tab 1 time into a list of keystrokes for that application / program.

 

Use 1st letter navigation, or whatever works best to get you to the keystroke you want to change / modify / remove.

 

With the keystroke highlighted, press the, Alt, key to open the menues, right arrow to the, Action, menu.

 

Now down arrow through the options to choose which of these options will best suit your needs, & press enter on it.  You can now tab through to see what choices you have in dealing with this keystroke.

 

Sorry but, this is as far as I can take you.  I truly hope this is what you're looking for.

Take care.
Mike
Sent from my iBarstool.  Go Dodgers!

----- Original Message -----

Sent: Sunday, May 07, 2017 7:21 PM

Subject: Re: Disabling a jaws keystroke for a particular app.

 

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@...> wrote:
> just an idea, have you tried pressing the bypass keystroke (insert+home
> row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
> send the next keystroke to the application being used instead of
> intercepting the keystroke.
>
> -------- Original Message --------
> From: Tony Malykh [mailto:anton.malykh@...]
> Sent: Saturday, May 6, 2017 6:38 PM EST
> To: main@jfw.groups.io
> Subject: Disabling a jaws keystroke for a particular app.
>
> Hello everyone,
>
> I am trying to press Alt+Shift+Up arrow in emacs However, at the same
> time, this keystoke happens to trigger jaws command "Mouse up". I aM
> not sure what does it do, but emacs never receives this keystroke,
> because jaws acts on it instead.
>
> Is there a way to disable a particular keystroke in jaws only for
> specific application? In my case, I'd like to disable Alt+Shift+Up
> arrow for Cygwin only. My emacs is running inside a Cygwin terminal.
>
> Or if there is no way to disable it for specific application, how do I
> disable or change a keystroke system-wide?
>
> Thanks
> Tony
>
>
>
> .
>
>
>
>
>
>


Mario
 

I agree it would be tedious. maybe you could write a simple script for
JAWS that would pass the Alt+Shift+Up arrow to Emax using a different
keystroke such as control+shift+up arrow if that combination is not used
for anything else. just another idea.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Sunday, May 7, 2017 10:21 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.









.


Tony Malykh
 

Thank you all for your tips!
I figured out how to use keyboard manager in jaws, and I deleted the
conflicting jaws keystrokes.

--Tony

On 5/8/17, Mario <mrb620@hotmail.com> wrote:
I agree it would be tedious. maybe you could write a simple script for
JAWS that would pass the Alt+Shift+Up arrow to Emax using a different
keystroke such as control+shift+up arrow if that combination is not used
for anything else. just another idea.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Sunday, May 7, 2017 10:21 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.









.






Mohith BP
 

Hi Tony,

Just adding to what Mike suggested.
You have to go to the Default as Alt+Shift +Up is a default keystroke.
Press Ctrl+Chift+D to go do default after you open Keyboard manager as
suggested by Mike.
In the list select "Mouse Up" you can type "mouse" quickly
or type m and use down-arrow.

I think in your case you may have to delete the alt+Shift+Up combination.


PS: You will not be able to use Mouse up command in your system. If
you have the necessity to use the command please change the keystroke
from the action menu instead of deleting it.

Thanks & Regards,
Mohith B. P.

On 5/8/17, Mike B. <mb69mach1@charter.net> wrote:
Hi Tony,

Open the Jaws Manager by pressing, Jaws key + F2, now press the letter, K,
until you get to, & press enter on Keyboard Manager. You'll be in a list of

applications, so use 1st letter navigation to get to the application /
program you want to work with.

Now, tab 1 time into a list of keystrokes for that application / program.

Use 1st letter navigation, or whatever works best to get you to the
keystroke you want to change / modify / remove.

With the keystroke highlighted, press the, Alt, key to open the menues,
right arrow to the, Action, menu.

Now down arrow through the options to choose which of these options will
best suit your needs, & press enter on it. You can now tab through to see
what choices you have in dealing with this keystroke.

Sorry but, this is as far as I can take you. I truly hope this is what
you're looking for.
Take care.
Mike
Sent from my iBarstool. Go Dodgers!
----- Original Message -----
From: Tony Malykh
To: main@jfw.groups.io
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.


That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.







Soronel Haetir
 

I would have suggested creating an emacs-specific script that simply
passes the keystroke on to the program, and then assigning the
keystroke in the key manager..

I think something like:

Script AltShiftUp()
TypeKey("Alt+Shift+Up")
EndScript

but it has been a long time since I've needed to do something like
this. I suggest this specifically because deleting a default keystroke
means it will no longer work in other programs (although alt+shift+up
is something I hardly ever use)

I believe you would also need to create a documentation file (.jsd)
which would be something like
:Script AltShiftUp
Passes the Alt+Shift+Up key combination on to the program

On 5/7/17, Mohith BP <mohith.ckm49@gmail.com> wrote:
Hi Tony,

Just adding to what Mike suggested.
You have to go to the Default as Alt+Shift +Up is a default keystroke.
Press Ctrl+Chift+D to go do default after you open Keyboard manager as
suggested by Mike.
In the list select "Mouse Up" you can type "mouse" quickly
or type m and use down-arrow.

I think in your case you may have to delete the alt+Shift+Up combination.


PS: You will not be able to use Mouse up command in your system. If
you have the necessity to use the command please change the keystroke
from the action menu instead of deleting it.

Thanks & Regards,
Mohith B. P.

On 5/8/17, Mike B. <mb69mach1@charter.net> wrote:
Hi Tony,

Open the Jaws Manager by pressing, Jaws key + F2, now press the letter,
K,
until you get to, & press enter on Keyboard Manager. You'll be in a list
of

applications, so use 1st letter navigation to get to the application /
program you want to work with.

Now, tab 1 time into a list of keystrokes for that application / program.

Use 1st letter navigation, or whatever works best to get you to the
keystroke you want to change / modify / remove.

With the keystroke highlighted, press the, Alt, key to open the menues,
right arrow to the, Action, menu.

Now down arrow through the options to choose which of these options will
best suit your needs, & press enter on it. You can now tab through to
see
what choices you have in dealing with this keystroke.

Sorry but, this is as far as I can take you. I truly hope this is what
you're looking for.
Take care.
Mike
Sent from my iBarstool. Go Dodgers!
----- Original Message -----
From: Tony Malykh
To: main@jfw.groups.io
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.


That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.








--
Soronel Haetir
soronel.haetir@gmail.com


Lisle, Ted (CHFS DMS)
 

May I offer one suggestion? I've said this before, but, if you tinker with that Default.JKM file, back it up first. Sure, you can go in and reedit, but it's much easier just to restore the original.

Ted

-----Original Message-----
From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of Soronel Haetir
Sent: Thursday, May 11, 2017 9:24 AM
To: main@jfw.groups.io
Subject: Re: Disabling a jaws keystroke for a particular app.

I would have suggested creating an emacs-specific script that simply
passes the keystroke on to the program, and then assigning the
keystroke in the key manager..

I think something like:

Script AltShiftUp()
TypeKey("Alt+Shift+Up")
EndScript

but it has been a long time since I've needed to do something like
this. I suggest this specifically because deleting a default keystroke
means it will no longer work in other programs (although alt+shift+up
is something I hardly ever use)

I believe you would also need to create a documentation file (.jsd)
which would be something like
:Script AltShiftUp
Passes the Alt+Shift+Up key combination on to the program


On 5/7/17, Mohith BP <mohith.ckm49@gmail.com> wrote:
Hi Tony,

Just adding to what Mike suggested.
You have to go to the Default as Alt+Shift +Up is a default keystroke.
Press Ctrl+Chift+D to go do default after you open Keyboard manager as
suggested by Mike.
In the list select "Mouse Up" you can type "mouse" quickly
or type m and use down-arrow.

I think in your case you may have to delete the alt+Shift+Up combination.


PS: You will not be able to use Mouse up command in your system. If
you have the necessity to use the command please change the keystroke
from the action menu instead of deleting it.

Thanks & Regards,
Mohith B. P.

On 5/8/17, Mike B. <mb69mach1@charter.net> wrote:
Hi Tony,

Open the Jaws Manager by pressing, Jaws key + F2, now press the letter,
K,
until you get to, & press enter on Keyboard Manager. You'll be in a list
of

applications, so use 1st letter navigation to get to the application /
program you want to work with.

Now, tab 1 time into a list of keystrokes for that application / program.

Use 1st letter navigation, or whatever works best to get you to the
keystroke you want to change / modify / remove.

With the keystroke highlighted, press the, Alt, key to open the menues,
right arrow to the, Action, menu.

Now down arrow through the options to choose which of these options will
best suit your needs, & press enter on it. You can now tab through to
see
what choices you have in dealing with this keystroke.

Sorry but, this is as far as I can take you. I truly hope this is what
you're looking for.
Take care.
Mike
Sent from my iBarstool. Go Dodgers!
----- Original Message -----
From: Tony Malykh
To: main@jfw.groups.io
Sent: Sunday, May 07, 2017 7:21 PM
Subject: Re: Disabling a jaws keystroke for a particular app.


That would work if I had to press Alt+Shift+Up only once. In my case,
Alt+Shift+Up moves a certain piece of text up by one position in emacs
org mode. I need to press it repeatedly 5-10 times. Alternating
Insert+3 and Alt+Shift+Up for 5 times is doable, but not very
practical.

Thanks for the tip though.

--Tony


On 5/6/17, Mario <mrb620@hotmail.com> wrote:
just an idea, have you tried pressing the bypass keystroke (insert+home
row 3) before issuing the alt+shift+up arrow? the bypass tells JAWS to
send the next keystroke to the application being used instead of
intercepting the keystroke.

-------- Original Message --------
From: Tony Malykh [mailto:anton.malykh@gmail.com]
Sent: Saturday, May 6, 2017 6:38 PM EST
To: main@jfw.groups.io
Subject: Disabling a jaws keystroke for a particular app.

Hello everyone,

I am trying to press Alt+Shift+Up arrow in emacs. However, at the same
time, this keystoke happens to trigger jaws command "Mouse up". I aM
not sure what does it do, but emacs never receives this keystroke,
because jaws acts on it instead.

Is there a way to disable a particular keystroke in jaws only for
specific application? In my case, I'd like to disable Alt+Shift+Up
arrow for Cygwin only. My emacs is running inside a Cygwin terminal.

Or if there is no way to disable it for specific application, how do I
disable or change a keystroke system-wide?

Thanks
Tony



.









--
Soronel Haetir
soronel.haetir@gmail.com