Initial Skype for desktop 8 feedback


Cristóbal
 

Hello list,

So, some initial feedback after updating to Skype 8.x

Muscle memory issues with the new keystrokes aside which are always going to take a bit getting used to, I’m finding certain aspects to be quite frustrating. I’ve already written Microsoft about some of this via the feedback option in the app as well as on Twitter.

Anyway, the immediate thing is that with this updated version, there doesn’t seem to be any means to have the Skype ringer alert go to a separate audio source like external or PC speakers. There’s only one option for speakers which if you’re using a headset, which I’m pretty sure most if not all of us are using is the only viable option. More so for those of us who have a paid number. The end result is that when you get an incoming call, the ringer quite easily drowns out anything Jaws (in my case) may say. I don’t use the audio ducking feature as I find it to be too distracting. One can go into the speaker settings in Skype and lower the volume or the speaker settings in Windows 10 to lower Skype volume, but all that accomplishes is that in addition to the ringer being lowered, the call audio is lowered as well. Also, I’ve already twice missed an incoming call because I took my headset off for this or that reason and didn’t hear the ringer alert fast enough through the headset to put it back on and get to the Skype window in time to pick up.

I had mentioned previously that the hotkeys also no longer to appear to be universal. Indeed, this is the case. So now, when you get an incoming call, you have to scramble to the Skype window since at least for me, I’m not taken there automatically and if I’m in a different virtual desktop, the taskbar short cut win key plus X, Y or Z won’t work and try to listen to figure out if I’m finally in the Skype window which again, as described previously, isn’t as easy since the ringer is drowning everything else out. The few times I’ve had a chance to take an incoming call and used the control plus shift plus P command, Skype actually initiates an outgoing call as well as answering the incoming call. This . . . has proven to be problematic to say the least.

More than once already, I’ve found myself trying to orientate myself on the Skype screen to maybe tab to the answer button instead of using the hotkey to avoid this issue with answering/making a duel call, but so far, I haven’t been able to access the answer/accept call button in time.

This leads me into the other issue. I so far have not been able to find any of the telephone settings for Skype. Settings in Skype appear to be super basic. Nothing however for voicemail greeting, managing call forwarding and or ringer time. I know I can probably if need be access some of these features via the Skype web account, but talk about a needless step backwards.

One other thing for Jaws users (I don’t use NVDA enough to know how the dictionary manager works), I had a bunch of saved entries for phone numbers to speak this or that clinic. It seems that the Skype app is Chrome based so, they didn’t port over. I’m sure I can go into my Jaws settings and try and play around with changing a dictionary manager file association, but again, just another inconvenience.

IN broad terms, the app all in all seems accessible and navigating around like a webpage is easy enough, but it lacks some serious functionality.

It is much easier to make calls, but receiving/answering… it’s still rough to say the least.

 


 

Why don’t you put Skype on the taskbar and then use Windows Key+whatever number to activate it when it rings? All the applications on your taskbar can be accessed this way, if you have Outlook as the first app, then Skype, Chrome, Excel you just press Windows Key+1 for OUtlook, Windows Key+2 for Skype, Windows Key+3 for Chrome ejtc.

 

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Cristóbal
Sent: Monday, July 30, 2018 4:15 PM
To: jfw@groups.io
Subject: Initial Skype for desktop 8 feedback

 

Hello list,

So, some initial feedback after updating to Skype 8.x

Muscle memory issues with the new keystrokes aside which are always going to take a bit getting used to, I’m finding certain aspects to be quite frustrating. I’ve already written Microsoft about some of this via the feedback option in the app as well as on Twitter.

Anyway, the immediate thing is that with this updated version, there doesn’t seem to be any means to have the Skype ringer alert go to a separate audio source like external or PC speakers. There’s only one option for speakers which if you’re using a headset, which I’m pretty sure most if not all of us are using is the only viable option. More so for those of us who have a paid number. The end result is that when you get an incoming call, the ringer quite easily drowns out anything Jaws (in my case) may say. I don’t use the audio ducking feature as I find it to be too distracting. One can go into the speaker settings in Skype and lower the volume or the speaker settings in Windows 10 to lower Skype volume, but all that accomplishes is that in addition to the ringer being lowered, the call audio is lowered as well. Also, I’ve already twice missed an incoming call because I took my headset off for this or that reason and didn’t hear the ringer alert fast enough through the headset to put it back on and get to the Skype window in time to pick up.

I had mentioned previously that the hotkeys also no longer to appear to be universal. Indeed, this is the case. So now, when you get an incoming call, you have to scramble to the Skype window since at least for me, I’m not taken there automatically and if I’m in a different virtual desktop, the taskbar short cut win key plus X, Y or Z won’t work and try to listen to figure out if I’m finally in the Skype window which again, as described previously, isn’t as easy since the ringer is drowning everything else out. The few times I’ve had a chance to take an incoming call and used the control plus shift plus P command, Skype actually initiates an outgoing call as well as answering the incoming call. This . . . has proven to be problematic to say the least.

More than once already, I’ve found myself trying to orientate myself on the Skype screen to maybe tab to the answer button instead of using the hotkey to avoid this issue with answering/making a duel call, but so far, I haven’t been able to access the answer/accept call button in time.

This leads me into the other issue. I so far have not been able to find any of the telephone settings for Skype. Settings in Skype appear to be super basic. Nothing however for voicemail greeting, managing call forwarding and or ringer time. I know I can probably if need be access some of these features via the Skype web account, but talk about a needless step backwards.

One other thing for Jaws users (I don’t use NVDA enough to know how the dictionary manager works), I had a bunch of saved entries for phone numbers to speak this or that clinic. It seems that the Skype app is Chrome based so, they didn’t port over. I’m sure I can go into my Jaws settings and try and play around with changing a dictionary manager file association, but again, just another inconvenience.

IN broad terms, the app all in all seems accessible and navigating around like a webpage is easy enough, but it lacks some serious functionality.

It is much easier to make calls, but receiving/answering… it’s still rough to say the least.

 


Cristóbal
 

Correct, but it won’t work when you’re working with multiple desktops.  

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Sieghard Weitzel
Sent: Tuesday, July 31, 2018 6:24 AM
To: main@jfw.groups.io
Subject: Re: Initial Skype for desktop 8 feedback

 

Why don’t you put Skype on the taskbar and then use Windows Key+whatever number to activate it when it rings? All the applications on your taskbar can be accessed this way, if you have Outlook as the first app, then Skype, Chrome, Excel you just press Windows Key+1 for OUtlook, Windows Key+2 for Skype, Windows Key+3 for Chrome ejtc.

 

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Cristóbal
Sent: Monday, July 30, 2018 4:15 PM
To: jfw@groups.io
Subject: Initial Skype for desktop 8 feedback

 

Hello list,

So, some initial feedback after updating to Skype 8.x

Muscle memory issues with the new keystrokes aside which are always going to take a bit getting used to, I’m finding certain aspects to be quite frustrating. I’ve already written Microsoft about some of this via the feedback option in the app as well as on Twitter.

Anyway, the immediate thing is that with this updated version, there doesn’t seem to be any means to have the Skype ringer alert go to a separate audio source like external or PC speakers. There’s only one option for speakers which if you’re using a headset, which I’m pretty sure most if not all of us are using is the only viable option. More so for those of us who have a paid number. The end result is that when you get an incoming call, the ringer quite easily drowns out anything Jaws (in my case) may say. I don’t use the audio ducking feature as I find it to be too distracting. One can go into the speaker settings in Skype and lower the volume or the speaker settings in Windows 10 to lower Skype volume, but all that accomplishes is that in addition to the ringer being lowered, the call audio is lowered as well. Also, I’ve already twice missed an incoming call because I took my headset off for this or that reason and didn’t hear the ringer alert fast enough through the headset to put it back on and get to the Skype window in time to pick up.

I had mentioned previously that the hotkeys also no longer to appear to be universal. Indeed, this is the case. So now, when you get an incoming call, you have to scramble to the Skype window since at least for me, I’m not taken there automatically and if I’m in a different virtual desktop, the taskbar short cut win key plus X, Y or Z won’t work and try to listen to figure out if I’m finally in the Skype window which again, as described previously, isn’t as easy since the ringer is drowning everything else out. The few times I’ve had a chance to take an incoming call and used the control plus shift plus P command, Skype actually initiates an outgoing call as well as answering the incoming call. This . . . has proven to be problematic to say the least.

More than once already, I’ve found myself trying to orientate myself on the Skype screen to maybe tab to the answer button instead of using the hotkey to avoid this issue with answering/making a duel call, but so far, I haven’t been able to access the answer/accept call button in time.

This leads me into the other issue. I so far have not been able to find any of the telephone settings for Skype. Settings in Skype appear to be super basic. Nothing however for voicemail greeting, managing call forwarding and or ringer time. I know I can probably if need be access some of these features via the Skype web account, but talk about a needless step backwards.

One other thing for Jaws users (I don’t use NVDA enough to know how the dictionary manager works), I had a bunch of saved entries for phone numbers to speak this or that clinic. It seems that the Skype app is Chrome based so, they didn’t port over. I’m sure I can go into my Jaws settings and try and play around with changing a dictionary manager file association, but again, just another inconvenience.

IN broad terms, the app all in all seems accessible and navigating around like a webpage is easy enough, but it lacks some serious functionality.

It is much easier to make calls, but receiving/answering… it’s still rough to say the least.

 


Steve Matzura
 

I can help with some of these.


All your Skype settings are under the menu you get  when you press the Profile button. In there, there are radio buttons for choosing audio devices for input, output and notification noises. What I can't find is the delay before going to voicemail, but it might be under Notifications, haven't looked at that branch of  Settings yet.


Speaking of voicemail, one of the Settings branches deals with the setup of voicemail and call forwarding.


HTH


On 7/30/2018 7:14 PM, Cristóbal wrote:

Hello list,

So, some initial feedback after updating to Skype 8.x

Muscle memory issues with the new keystrokes aside which are always going to take a bit getting used to, I’m finding certain aspects to be quite frustrating. I’ve already written Microsoft about some of this via the feedback option in the app as well as on Twitter.

Anyway, the immediate thing is that with this updated version, there doesn’t seem to be any means to have the Skype ringer alert go to a separate audio source like external or PC speakers. There’s only one option for speakers which if you’re using a headset, which I’m pretty sure most if not all of us are using is the only viable option. More so for those of us who have a paid number. The end result is that when you get an incoming call, the ringer quite easily drowns out anything Jaws (in my case) may say. I don’t use the audio ducking feature as I find it to be too distracting. One can go into the speaker settings in Skype and lower the volume or the speaker settings in Windows 10 to lower Skype volume, but all that accomplishes is that in addition to the ringer being lowered, the call audio is lowered as well. Also, I’ve already twice missed an incoming call because I took my headset off for this or that reason and didn’t hear the ringer alert fast enough through the headset to put it back on and get to the Skype window in time to pick up.

I had mentioned previously that the hotkeys also no longer to appear to be universal. Indeed, this is the case. So now, when you get an incoming call, you have to scramble to the Skype window since at least for me, I’m not taken there automatically and if I’m in a different virtual desktop, the taskbar short cut win key plus X, Y or Z won’t work and try to listen to figure out if I’m finally in the Skype window which again, as described previously, isn’t as easy since the ringer is drowning everything else out. The few times I’ve had a chance to take an incoming call and used the control plus shift plus P command, Skype actually initiates an outgoing call as well as answering the incoming call. This . . . has proven to be problematic to say the least.

More than once already, I’ve found myself trying to orientate myself on the Skype screen to maybe tab to the answer button instead of using the hotkey to avoid this issue with answering/making a duel call, but so far, I haven’t been able to access the answer/accept call button in time.

This leads me into the other issue. I so far have not been able to find any of the telephone settings for Skype. Settings in Skype appear to be super basic. Nothing however for voicemail greeting, managing call forwarding and or ringer time. I know I can probably if need be access some of these features via the Skype web account, but talk about a needless step backwards.

One other thing for Jaws users (I don’t use NVDA enough to know how the dictionary manager works), I had a bunch of saved entries for phone numbers to speak this or that clinic. It seems that the Skype app is Chrome based so, they didn’t port over. I’m sure I can go into my Jaws settings and try and play around with changing a dictionary manager file association, but again, just another inconvenience.

IN broad terms, the app all in all seems accessible and navigating around like a webpage is easy enough, but it lacks some serious functionality.

It is much easier to make calls, but receiving/answering… it’s still rough to say the least.

 



Cristóbal
 

There are three buttons at the top of the screen. My info, the one where it says my Skype ID and a more button.

If I click on either one of the first two, I’m taken to another screen where the below is displayed:

Close settings Button
Your name
Edit My Skype Name
Tell your friends what you’re up to
Edit Tell your friends what you’re up to
Your presence status is Invisible
Button
Edit Tell your friends what you’re up to
Edit Tell your friends what you’re up to
Your presence status is Invisible
Button
Share profile
Button
Skype Credit and Subscriptions. Your Skype Credit balance is $0.00 and you have 1 subscription.
Button
blank
Application Settings
Button
Audio & Video Settings
Button
Calling
Button
Account and profile
Button
Money
Button
Language
Button
blank
Skype Name
My Skype ID
Skype Number +***********
Button
Birthday
**********
Color, currently selected: Blue
Button
Theme
Button
blank
Help and feedback
Button
Get Skype for Mobile
Button
About
Button
Sign out Button
Sign out Button

The voice mail and call forwarding stuff is in the call button and all the audio stuff is under the audio and video settings, but for me at least,

The ability to separate the ring alerts from the call audio doesn’t show up. This is what’s on the audio and video settings on my screen:

Audio & Video Settings
blank
Make a free test call
Button
Microphone
Microphone, Microphone (2- Logitech USB Headset), selected
button menu
blank
Automatically adjust microphone settings
 Automatically adjust microphone settings Switch On
blank
Speakers
Speakers, Speakers (2- Logitech USB Headset), selected
button menu
Change speaker volume
2
left right slider
Start audio test
Button
blank
Camera
No device found. Link Learn more about fixing this issue.
issue

This is on my desktop and I don’t’ have a webcam installed, thus the last message.

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Steve Matzura
Sent: Tuesday, July 31, 2018 9:20 AM
To: main@jfw.groups.io
Subject: Re: Initial Skype for desktop 8 feedback

 

I can help with some of these.

 

All your Skype settings are under the menu you get  when you press the Profile button. In there, there are radio buttons for choosing audio devices for input, output and notification noises. What I can't find is the delay before going to voicemail, but it might be under Notifications, haven't looked at that branch of  Settings yet.

 

Speaking of voicemail, one of the Settings branches deals with the setup of voicemail and call forwarding.

 

HTH

 

On 7/30/2018 7:14 PM, Cristóbal wrote:

Hello list,

So, some initial feedback after updating to Skype 8.x

Muscle memory issues with the new keystrokes aside which are always going to take a bit getting used to, I’m finding certain aspects to be quite frustrating. I’ve already written Microsoft about some of this via the feedback option in the app as well as on Twitter.

Anyway, the immediate thing is that with this updated version, there doesn’t seem to be any means to have the Skype ringer alert go to a separate audio source like external or PC speakers. There’s only one option for speakers which if you’re using a headset, which I’m pretty sure most if not all of us are using is the only viable option. More so for those of us who have a paid number. The end result is that when you get an incoming call, the ringer quite easily drowns out anything Jaws (in my case) may say. I don’t use the audio ducking feature as I find it to be too distracting. One can go into the speaker settings in Skype and lower the volume or the speaker settings in Windows 10 to lower Skype volume, but all that accomplishes is that in addition to the ringer being lowered, the call audio is lowered as well. Also, I’ve already twice missed an incoming call because I took my headset off for this or that reason and didn’t hear the ringer alert fast enough through the headset to put it back on and get to the Skype window in time to pick up.

I had mentioned previously that the hotkeys also no longer to appear to be universal. Indeed, this is the case. So now, when you get an incoming call, you have to scramble to the Skype window since at least for me, I’m not taken there automatically and if I’m in a different virtual desktop, the taskbar short cut win key plus X, Y or Z won’t work and try to listen to figure out if I’m finally in the Skype window which again, as described previously, isn’t as easy since the ringer is drowning everything else out. The few times I’ve had a chance to take an incoming call and used the control plus shift plus P command, Skype actually initiates an outgoing call as well as answering the incoming call. This . . . has proven to be problematic to say the least.

More than once already, I’ve found myself trying to orientate myself on the Skype screen to maybe tab to the answer button instead of using the hotkey to avoid this issue with answering/making a duel call, but so far, I haven’t been able to access the answer/accept call button in time.

This leads me into the other issue. I so far have not been able to find any of the telephone settings for Skype. Settings in Skype appear to be super basic. Nothing however for voicemail greeting, managing call forwarding and or ringer time. I know I can probably if need be access some of these features via the Skype web account, but talk about a needless step backwards.

One other thing for Jaws users (I don’t use NVDA enough to know how the dictionary manager works), I had a bunch of saved entries for phone numbers to speak this or that clinic. It seems that the Skype app is Chrome based so, they didn’t port over. I’m sure I can go into my Jaws settings and try and play around with changing a dictionary manager file association, but again, just another inconvenience.

IN broad terms, the app all in all seems accessible and navigating around like a webpage is easy enough, but it lacks some serious functionality.

It is much easier to make calls, but receiving/answering… it’s still rough to say the least.