moderated audio ducking and Jaws and cortanna


Nino Dagostino
 

Good morning:

 

Is there a way to turn off audio ducking so when using cortanna jaws ducks so low you cant here any thing from Jaws?

 

Any help would be appreciated.

 

 


Dan Longmore
 

 Audio ducking should reduce the volume of other programs other than jars. That setting is in the jaws settings. Also go to your system volume settings and you should be able to reduce Cortana is volume separate from all the others in the system volume settings. 


From: main@jfw.groups.io <main@jfw.groups.io> on behalf of Nino Dagostino <ndagostino3@...>
Sent: Tuesday, June 26, 2018 7:49:30 AM
To: main@jfw.groups.io
Subject: audio ducking and Jaws and cortanna
 

Good morning:

 

Is there a way to turn off audio ducking so when using cortanna jaws ducks so low you cant here any thing from Jaws?

 

Any help would be appreciated.

 

 


 

I no longer have JAWS, so what follows is sketchy and from memory, but isn't it possible to put JAWS into "no voice" mode or actually sleep JAWS entirely when focus is on specific applications?  This ability exists in NVDA, and I could have sworn it existed in JAWS, too, but the details of implementing it have escaped me.  One generally wants JAWS to shut up when dealing with other apps that are self-voicing. 
--

Brian - Windows 10 Home, 64-Bit, Version 1803, Build 17134  

     Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. Broad, wholesome, charitable views of men and things cannot be acquired by vegetating in one little corner of the earth all one's lifetime.

         ~ Mark Twain


 

Hi,

If I’m understanding Nino’s post correctly, he wants JAWS to stay silent when interacting with Cortana, not the other way around. Is this correct?

It is tricky to implement application sleep mode for Cortana, because it’ll affect Start menu as well.

Technical: in Windows 10, Cortana and Start menu are housed inside one executable: SearchUI.exe. This is the reason why you’d hear “Cortana” when you open Start menu. If application sleep mode is applied to SearchUI.exe, not only JAWS would stay silent, Start menu interaction won’t work properly.

There is a way to let JAWS stay silent when you talk to Cortana: scripting SearchUI.exe (searchui.jss). The idea is to catch UIA events on a particular control and force JAWS to stay silent as long as a particular event is occurring on that UIA element (trust me, it took me months to get it right for another screen reader; talk to me privately if you have questions on how I did it for NVDA).

Cheers,

Joseph

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, June 26, 2018 8:23 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

I no longer have JAWS, so what follows is sketchy and from memory, but isn't it possible to put JAWS into "no voice" mode or actually sleep JAWS entirely when focus is on specific applications?  This ability exists in NVDA, and I could have sworn it existed in JAWS, too, but the details of implementing it have escaped me.  One generally wants JAWS to shut up when dealing with other apps that are self-voicing. 
--

Brian - Windows 10 Home, 64-Bit, Version 1803, Build 17134  

     Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. Broad, wholesome, charitable views of men and things cannot be acquired by vegetating in one little corner of the earth all one's lifetime.

         ~ Mark Twain


Sieghard Weitzel <sieghard@...>
 

I would highly recommend you turn off audio ducking since that feature is not working correctly. I don’t even know why the feature is still there since FS seems to have abandoned it. I would also write to FS and ask them why they are not either decide to fix it or take it out.

When I just tried it again using the Windows 10 Audible app (the one from the Windows store) the audio book was quieter with audio ducking on, but the volume did not come up even if I didn’t touch the keuyboard. As soon as I turned audio ducking off with the layered key command Jaws Key+Spacebar and D, the audio book volume came up, as soon as I turned it on it went down and stayed down.

I am a Jaws beta tester as well and this has come up on the beta list not that long ago and there was no response from FS regarding this feature. It was first introduced I think maybe with Windows 8 or 8.1, at some point FS announced the feature was not working correctly and it would be disabled for now, now it does seem to do something except it is not how it is supposed to work.

With the support for multiple audio devices in Windows 10 April update I think the best solution is to have Jaws on a dedicated audio device.

 

Regards,

Sieghard

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, June 26, 2018 8:23 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

I no longer have JAWS, so what follows is sketchy and from memory, but isn't it possible to put JAWS into "no voice" mode or actually sleep JAWS entirely when focus is on specific applications?  This ability exists in NVDA, and I could have sworn it existed in JAWS, too, but the details of implementing it have escaped me.  One generally wants JAWS to shut up when dealing with other apps that are self-voicing. 
--

Brian - Windows 10 Home, 64-Bit, Version 1803, Build 17134  

     Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. Broad, wholesome, charitable views of men and things cannot be acquired by vegetating in one little corner of the earth all one's lifetime.

         ~ Mark Twain


Bill White <billwhite92701@...>
 

What Nino wants is to find out how to prevent JAWS from being lowered when he gets an alarm notice from Cortana. When Nino gets a notice now, he can’t hear JAWS tell him for what time the alarm is set. Audio Ducking is not on, neither is the Communications tab set to reduce JAWS. We think this is a function of Cortana for which there is no way to prevent the JAWS audio from being lowered.

 

Bill White

billwhite92701@...

 

From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of Joseph Lee
Sent: Tuesday, June 26, 2018 8:37 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

Hi,

If I’m understanding Nino’s post correctly, he wants JAWS to stay silent when interacting with Cortana, not the other way around. Is this correct?

It is tricky to implement application sleep mode for Cortana, because it’ll affect Start menu as well.

Technical: in Windows 10, Cortana and Start menu are housed inside one executable: SearchUI.exe. This is the reason why you’d hear “Cortana” when you open Start menu. If application sleep mode is applied to SearchUI.exe, not only JAWS would stay silent, Start menu interaction won’t work properly.

There is a way to let JAWS stay silent when you talk to Cortana: scripting SearchUI.exe (searchui.jss). The idea is to catch UIA events on a particular control and force JAWS to stay silent as long as a particular event is occurring on that UIA element (trust me, it took me months to get it right for another screen reader; talk to me privately if you have questions on how I did it for NVDA).

Cheers,

Joseph

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, June 26, 2018 8:23 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

I no longer have JAWS, so what follows is sketchy and from memory, but isn't it possible to put JAWS into "no voice" mode or actually sleep JAWS entirely when focus is on specific applications?  This ability exists in NVDA, and I could have sworn it existed in JAWS, too, but the details of implementing it have escaped me.  One generally wants JAWS to shut up when dealing with other apps that are self-voicing. 
--

Brian - Windows 10 Home, 64-Bit, Version 1803, Build 17134  

     Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. Broad, wholesome, charitable views of men and things cannot be acquired by vegetating in one little corner of the earth all one's lifetime.

         ~ Mark Twain


Sieghard Weitzel <sieghard@...>
 

The alarm/Cortana sounds probably just dominate Jaws, this happens also sometimes when you go on a website where some video ad starts playing and suddenly you can hardly hear Jaws anymore because of the other audio.

If audio ducking works correctly it is actually supposed to duck/lower other audio not Jaws so that as soon as you use Jaws you can actually hear it and find a button or whatever to turn off the alarm or to stop the video from playing.

As I said before, there is no good solution without a separate sound card or USB sound device. I just received an email from AT Guys, they are selling an USB audio device which has a 3.5mm headphone speaker jack and a 3.5mm microphone jack for $10, here is the link:

 

Aluminum USB External Stereo Sound Adapter for Windows and Mac

 

I am considering ordering at least 3 or 4 of these things for my various computers so I can finally separate Jaws and other audio.

 

 

Regards,

Sieghard

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Bill White
Sent: Tuesday, June 26, 2018 9:30 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

What Nino wants is to find out how to prevent JAWS from being lowered when he gets an alarm notice from Cortana. When Nino gets a notice now, he can’t hear JAWS tell him for what time the alarm is set. Audio Ducking is not on, neither is the Communications tab set to reduce JAWS. We think this is a function of Cortana for which there is no way to prevent the JAWS audio from being lowered.

 

Bill White

billwhite92701@...

 

From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of Joseph Lee
Sent: Tuesday, June 26, 2018 8:37 AM
To:
main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

Hi,

If I’m understanding Nino’s post correctly, he wants JAWS to stay silent when interacting with Cortana, not the other way around. Is this correct?

It is tricky to implement application sleep mode for Cortana, because it’ll affect Start menu as well.

Technical: in Windows 10, Cortana and Start menu are housed inside one executable: SearchUI.exe. This is the reason why you’d hear “Cortana” when you open Start menu. If application sleep mode is applied to SearchUI.exe, not only JAWS would stay silent, Start menu interaction won’t work properly.

There is a way to let JAWS stay silent when you talk to Cortana: scripting SearchUI.exe (searchui.jss). The idea is to catch UIA events on a particular control and force JAWS to stay silent as long as a particular event is occurring on that UIA element (trust me, it took me months to get it right for another screen reader; talk to me privately if you have questions on how I did it for NVDA).

Cheers,

Joseph

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Brian Vogel
Sent: Tuesday, June 26, 2018 8:23 AM
To: main@jfw.groups.io
Subject: Re: audio ducking and Jaws and cortanna

 

I no longer have JAWS, so what follows is sketchy and from memory, but isn't it possible to put JAWS into "no voice" mode or actually sleep JAWS entirely when focus is on specific applications?  This ability exists in NVDA, and I could have sworn it existed in JAWS, too, but the details of implementing it have escaped me.  One generally wants JAWS to shut up when dealing with other apps that are self-voicing. 
--

Brian - Windows 10 Home, 64-Bit, Version 1803, Build 17134  

     Travel is fatal to prejudice, bigotry, and narrow-mindedness, and many of our people need it sorely on these accounts. Broad, wholesome, charitable views of men and things cannot be acquired by vegetating in one little corner of the earth all one's lifetime.

         ~ Mark Twain


Ashleigh Piccinino
 

I’m not sure I understand your question. You can turn off or on the audio ducking feature in your JAWS startup wizard. To get there, move to the JAWS window—insert j on a desktop keyboard, caplock j on a laptop, I guess. Press alt h to get to your help and up arrow until you hear “startup wizard.” Press enter on this. On the first page, right after “keyboard echo,” is the audio ducking setting. However, it says “Lower the volume of other programs while JAWS is speaking.” Note that other is in itallics in this message to emphasize. To my knowledge, and when I could use Cortana correctly with mike, JAWS did lower a lot so you heard the Cortana itself. I’m not sure you can duck JAWS itself, though—that’s for other programs/used for videos and stuff but isn’t working right now. Of course, I’m talking about the audio ducking feature. Need any more help? Feel free to contact back/contact the group.

Thank you,

Ashleigh Piccinino

 

Sent from Mail for Windows 10

 


From: main@jfw.groups.io <main@jfw.groups.io> on behalf of Nino Dagostino <ndagostino3@...>
Sent: Tuesday, June 26, 2018 6:49:30 AM
To: main@jfw.groups.io
Subject: audio ducking and Jaws and cortanna
 

Good morning:

 

Is there a way to turn off audio ducking so when using cortanna jaws ducks so low you cant here any thing from Jaws?

 

Any help would be appreciated.