JAWS with a slow-moving PC cursor...?

Nikhil Nair

Hi folks,

This might be a bit obscure, but I hope someone will be able to point me in the right direction.

I regularly use a terminal program to access a remote Linux-based server; I tend to use SecureCRT, because I like the accessibility, but this aspect would be the same with any other terminal program (e.g. PuTTY), and may even crop up in non-terminal environments.

The issue: if the latency of the Internet connection isn't ideal, then sometimes, when I move the cursor left/right one character at a time with the left/right arrow keys, JAWS reads the current character rather than the one I'm moving to, because the latency of the connection causes the actual cursor movement to be slower than whatever timeout JAWS uses to determine whether the cursor is going to move or not. Of course, exactly the same happens when moving up/down, with JAWS reading the current line, rather than the one I'm moving to.

This can be particularly annoying when it doesn't happen with every keystroke, but happens intermittently - presumably because the latency of the connection is hovering around JAWS's timeout, sometimes greater, sometimes less.

So... is there an easy solution to this? Is that timeout something I can adjust - and if so, how?

BTW, I'm using JAWS 13 (since I had some stability problems with 14, on Windows XP). Hopefully that isn't relevant, however.



Lee Maschmeyer

Hi Nikhil,

I have a couple guesses as to why Jaws doesn't see the cursor movements fast enough. They could be dead wrong of course...

Linux cursors generally don't blink. But Jaws uses cursor blink as (one of?) the means to determine the cursor's location. Can you configure your terminal program to blink the cursor?

I'm using Jaws 14 which may make a bit of difference here. Under Miscellaneous Settings in Settings Center there's one called Text Out Delay. It's set to 0 by default but if you increase this it delays Jaws from speaking for the specified number of milliseconds. This might possibly help to prevent Jaws from talking before it figures out the cursor has moved. Try it and if it doesn't help, you might want to set it back to 0.

And, if you really want to grasp at straws, read default.jcf with an editor. There may be something in there that isn't accessible through Settings Center that you can change on your own; I seem to remember something about the amount of time Jaws waits to give up on locating the cursor.

WRT stability in Jaws 14, try applying all the updates and then destroy your personal settings. I think there were problems with early releases of 14 that have been addressed recently. Just my two cents worth...

Good luck,


Lee Maschmeyer

"Never imagine yourself not to be otherwise than what it might appear to others that what you were or might have been was not otherwise than what you had been would have appeared to them to be otherwise."
--Lewis Carroll