moderated Re: browsing with Firefox 89


Richard Turner
 

Mario,
I'm copying your message from the other thread as that may solve his issue too. It certainly vastly sped up how well Firefox 89 works with Jaws 2020 on my system and I think helped a little with Jaws 2021 which worked better anyway, but this fix seems to do the trick:
Original message from Mario:
Richard and all, I am using the latest version of JAWS 2020, and cannot upgrade to 2021 yet. I've also tried NVDA and Narrator and still have no access. however, I red the discussion and possible fix/work around at the following thread:

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fbugzilla.mozilla.org%2Fshow_bug.cgi%3Fid%3D1714212&;data=04%7C01%7C%7Ce50fe1c4473a421aaf2608d9279cdd4a%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637584376937722832%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&sdata=lHtLwuQDn99vfXaGQy3t%2BjW49NKnFOwwhZceERIqlQs%3D&reserved=0

1. Start Firefox.
2. Enter the address about:config in the address bar.
3. Accept the warning.
4. In the search box, enter the word skeleton 5. In the table below, browser.startup.preXulSkeletonUI should appear and it will have a value of true. Press the Toggle button to set it to false.
6. Restart Firefox.

this works, as I now can use JAWS, NVDA or Narrator with Firefox as if there wasn't any problem.

I don't know exactly what the feature does, but it was mentioned that it might have been left on true unintentionally before releasing FF 89.0.


Richard
Software means never having to say you're finished

Web site: www.turner42.com

-----Original Message-----
From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Mario
Sent: Friday, June 4, 2021 2:17 PM
To: main@jfw.groups.io
Subject: Re: browsing with Firefox 89

Soronel, I don't think the reset/refresh procedure is meant as a permanent fix. it is there for troubleshooting purposes.


-------- Original Message --------
From: Soronel Haetir [mailto:soronel.haetir@gmail.com]
Subject: browsing with Firefox 89
Date: Friday, June 4, 2021, 1:56 PM
To: main@jfw.groups.io
I really don't understand what's going on. After restarting after the
mentioned refresh FF stopped working again, I had to redo the Help ->
Troubleshooting -> Restart -> Refresh cycle for FF to work again.

And unfortunately, in whatever mode this is FF won't actually tell me
what extensions/plugins are installed so it is very difficult to try
messing with them to figure out where the problem is.

On 6/4/21, Richard Turner <richardturner42@outlook.com> wrote:
Good to know.
So, maybe it isn't Firefox but something else on people's systems.

It sounds like others are having similar issues.



Richard
Software means never having to say you're finished

Web site: https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.turner42.com%2F&;data=04%7C01%7C%7C62efcf1c8c954d4f332508d9279e13a0%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C637584382150000658%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=XddCysnFD%2FtOw33n9ofM4Om4o2SM58BZCYQPfTKj88M%3D&amp;reserved=0



-----Original Message-----
From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Soronel Haetir
Sent: Friday, June 4, 2021 9:42 AM
To: main@jfw.groups.io
Subject: Re: browsing with Firefox 89

I did the 'refresh' offered as part of Firefox's troubleshooting mode and
now it works again. And yes, this is 89.0.

On 6/4/21, Daniel Wolak <danielwolak97@hotmail.com> wrote:
I am by no means an expert, but assuming this issue is the same
Mozilla is already aware of this and there are several comments that
explain the issue in more detail.

A possible fix is also mentioned.

See here:

https://na01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fbugzi
lla.mozilla.org%2Fshow_bug.cgi%3Fid%3D1714212&amp;data=04%7C01%7C%7C6b
5474c1ff9d4c01986308d92777a219%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%
7C0%7C637584217029042654%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiL
CJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=gceGbaJ
IWR7aVl3TeJa44c%2BNYXP9XYJ8n2HgEF5iK2o%3D&amp;reserved=0


Hth a bit,


Daniel


On 2021-06-04 12:32 p.m., Soronel Haetir wrote:
I am experiencing exactly the issue you describe. I took the time to
examine the UIA tree with an accessibility test tool and while the
menu and toolbar buttons show up as normal there is simply no node
for the page content.


On 6/4/21, Mario <mrb620@hotmail.com> wrote:
on occasion, I will use Firefox to browse a website, and recently it
was upgraded to version 89.0. now I find that after starting FF and
browsing to a website using JAWS 2020,I am not able to navigate any
website even though it's home page is open.

has anyone experience this, and any fixes for this problem? and
please don't tell me to use another browser.
















--
Soronel Haetir
soronel.haetir@gmail.com

Join main@jfw.groups.io to automatically receive all group messages.