moderated Re: JAWS 2021 and Brave Browser: Not Allowing Me To Navigate With Left/Right Arrow Keys In The Address Bar


James Benstead
 

Hi Bill,

Have you ever tried using some of version control (like git or SVN) to manage your JAWS settings? Once it was set up it might make it easier to revert changes that have been made to settings (if I'm right in my assumption that JAWS settings files are all plain text).

Jim

--
Too brief? Here's why! http://emailcharter.org


On Thu, 24 Dec 2020 at 07:15, Bill White <billwhite92701@...> wrote:

Hi, David. One way I have found to avoid problems with JAWS and apps is to avoid using the JAWS Settings migration feature between versions of JAWS. I make all changes to JAWS settings in new versions of JAWS manually. I also make a file noting all changes which I have made to JAWS that change default behavior. This way, If I see that something is not working as desired with JAWS, I check by using the INSERT plus SPACE, followed by Z command. If the undesired behavior does not persist when Default alternate user directory mode is enabled, I have a complete list of changes I have made to JAWS Default Settings, and can reverse them to see which of these changes has resulted in the undesired behavior of JAWS.

 

 

From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of David Goldfield
Sent: Wednesday, December 23, 2020 7:58 PM
To: main@jfw.groups.io
Subject: Re: JAWS 2021 and Brave Browser: Not Allowing Me To Navigate With Left/Right Arrow Keys In The Address Bar

 

Bill,

Thanks so much for your suggestion, which led me to the solution. After a bit of trial and error I discovered that it was my default.jcf file which was causing the odd behavior in Brave. Once I discovered this I removed it, adjusted some default settings and things are working perfectly now. Thank you again for helping me to troubleshoot and correct this annoying behavior.

 

 

David Goldfield,

Blindness Assistive Technology Specialist

WWW.DavidGoldfield.org

 

From: main@jfw.groups.io <main@jfw.groups.io> On Behalf Of Bill White
Sent: Wednesday, December 23, 2020 5:00 PM
To: main@jfw.groups.io
Subject: Re: JAWS 2021 and Brave Browser: Not Allowing Me To Navigate With Left/Right Arrow Keys In The Address Bar

 

Hi, David. The only thing I can recommend is, before you do your repair, go into Utilities>Explore My Settings, and remove all settings files. This is based on the behavior of INSERT plus SPACE, followed by Z. This runs JAWS with no settings configuration files in effect. Then do a JAWS repair, and see if this fixes the problem.

 

 

From: main@jfw.groups.io [mailto:main@jfw.groups.io] On Behalf Of David Goldfield
Sent: Wednesday, December 23, 2020 1:07 PM
To: jfw@groups.io
Subject: JAWS 2021 and Brave Browser: Not Allowing Me To Navigate With Left/Right Arrow Keys In The Address Bar

 

First, I want to say that the problem I’m about to describe is likely not a reproducible JAWS bug but is something which seems to be some sort of corruption unique to my profile.

I’m using JAWS 2021, Brave 1.18.75, Windows 10 Pro, 20H2, Dell Lattitude E7270.

This problem did not occur using my old Dell OptiPlex.

The problem does not occur with other browsers.

When I open a page in Brave all navigation commands work as expected until I navigate to the address bar by either pressing ctrl-L or alt-D.

When the address bar gains focus JAWS speaks it as it should. However, cursor navigation commands do not speak as I navigate with left/right arrow keys and selection commands along with ctrl-C do not allow me to copy the URL to the clipboard.

If I press insert-space, followed by Z to open a temporary default profile navigation commands work as expected.

As soon as I toggle back to my own profile I cannot navigate, select or copy the URL.

Here is what I have done so far.

  1. Run the JAWS 2021 installer to initiate a repair. Same behavior after the repair.
  2. As I use Leasey I then uninstalled that program. Restarting the PC without Leasey still did not fix the problem.
  3. Reinstalled Leasey with no change after PC restart.

I’m wondering if there are specific files in my user settings folder (not shared settings) which I could delete to see if that might fix the issue.

Feedback is appreciated.

 

 

David Goldfield,

Blindness Assistive Technology Specialist

WWW.DavidGoldfield.org

 

Join main@jfw.groups.io to automatically receive all group messages.